请选择 进入手机版 | 继续访问电脑版
查看: 777|回复: 18

[易语言] 火牛视频v1.2.8 ak算法源代码开源

[复制链接]

111

主题

111

帖子

337

积分

中级会员

Rank: 3Rank: 3

积分
337
发表于 2018-8-22 08:54:58 | 显示全部楼层 |阅读模式

本帖子中包含更多资源,您需要登录才可以下载或查看更多内容!

您需要 登录 才可以下载附件,没有帐号?注册账号入驻无名

火牛视频v1.2.8 ak算法源代码开源
ak的签名计算过程其实就是几个字符串按照特定的顺序进行拼接,最后经过MD5.
几个版本下来变化不大,就是多了两参数.

火牛视频v1.2.8 ak算法源代码开源

火牛视频v1.2.8 ak算法源代码开源

加密是在jni层进行'libwq_core.so' 的方法'a',自个去看看哈.

火牛视频v1.2.8 ak算法源代码开源

火牛视频v1.2.8 ak算法源代码开源

火牛视频v1.2.8 ak算法源代码开源

火牛视频v1.2.8 ak算法源代码开源

  1. .版本 2
  2. .支持库 dp1

  3. .子程序 test
  4. .局部变量 待加密数据, 文本型
  5. .局部变量 加密结果, 文本型
  6. .局部变量 固定字符串, 文本型
  7. .局部变量 原始数据顺序, 文本型

  8. 原始数据顺序 = “imei串码.apk版本.app名称.app平台.app包名.请求链接路径部分.时间戳.到文本((时间戳)%3)”
  9. ' *** 缩略程序块 ***
  10. ' 而这些数据除了包名都能在请求链接里面找到
  11. ' 以发送验证码为例
  12. ' https://www.feixun.tv/api/v1/user/getCheckCode.json?platform=and&appName=firebull&smid=201806251149584eb20c163e82dfc33fdd6f03bfb2bab50177926f6ecbb88d&sid=865166028768342&partner=0061&appVersion=1.2.8&brand=Letv&model=X600&isWifi=true&osVersion=21&lhNum=6&phone=13800138004&ticket=CH9aM-hnWWWgCk6mG37dZME6U2rrCTh4wGlPSSrDeKGfCG-BXTrpJer90vJGe2ONSEvtHvmsTUw*&ts=1534854265&ak=75a6990994f48ca92d924d83e0620649
  13. ' IMEI串码:sid:865166028768342
  14. ' apk版本:1.2.8
  15. ' app名称:firebull
  16. ' 平台:and
  17. ' apk包名:com.waqu.android.firebull
  18. ' 路径:/api/v1/user/getCheckCode.json
  19. ' 时间戳:1534854265
  20. ' 时间戳取余:时间戳%3
  21. 固定字符串 = “waqu_and_6.4.0_0403bj”
  22. 待加密数据 = 固定字符串 + “865166028768342” + “1.2.8” + “firebull” + “and” + “com.waqu.android.firebull” + “/api/v1/user/getCheckCode.json” + “1534854265” + 到文本 (到整数 (1534854265) % 3)
  23. 加密结果 = 取数据摘要 (到字节集 (待加密数据))
  24. 信息框 (“验证结果:” + 到文本 (加密结果 = “75a6990994f48ca92d924d83e0620649”), 0, , )
复制代码

火牛视频APP-ak.zip

1.74 KB, 下载次数: 3

回复

使用道具 举报

0

主题

1279

帖子

2568

积分

金牌会员

Rank: 6Rank: 6

积分
2568
发表于 2018-8-24 15:12:03 | 显示全部楼层
我不是来抢沙发的,也不是来打酱油的。
回复

使用道具 举报

0

主题

870

帖子

1742

积分

金牌会员

Rank: 6Rank: 6

积分
1742
发表于 2018-8-25 21:51:32 | 显示全部楼层
不要在一棵树上吊死,在附近几棵树上多试试死几次~
回复

使用道具 举报

0

主题

1228

帖子

2470

积分

金牌会员

Rank: 6Rank: 6

积分
2470
发表于 2018-8-27 20:10:50 | 显示全部楼层
如果回帖是一种美德,那我早就成为圣人了!
回复

使用道具 举报

0

主题

868

帖子

1738

积分

金牌会员

Rank: 6Rank: 6

积分
1738
发表于 2018-8-29 10:06:01 | 显示全部楼层
要是我灌水,就骂我“三个代表”没学好吧。
回复

使用道具 举报

0

主题

1084

帖子

2170

积分

金牌会员

Rank: 6Rank: 6

积分
2170
发表于 2018-8-30 21:00:09 | 显示全部楼层
不要在一棵树上吊死,在附近几棵树上多试试死几次~
回复

使用道具 举报

0

主题

923

帖子

1848

积分

金牌会员

Rank: 6Rank: 6

积分
1848
发表于 2018-8-31 10:45:15 | 显示全部楼层
爱护环境,人人有病。
回复

使用道具 举报

0

主题

344

帖子

692

积分

高级会员

Rank: 4

积分
692
发表于 2018-9-5 10:32:02 | 显示全部楼层
义无返顾的顶顶了!
回复

使用道具 举报

0

主题

842

帖子

1686

积分

金牌会员

Rank: 6Rank: 6

积分
1686
发表于 2018-9-8 11:34:44 | 显示全部楼层
在这个处处都要积分的时代
回复

使用道具 举报

0

主题

854

帖子

1712

积分

金牌会员

Rank: 6Rank: 6

积分
1712
发表于 2018-9-11 11:43:38 | 显示全部楼层
此事与本人一点关系也没有,本人只是来回帖子赚1分苦力的;
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表