查看: 1748|回复: 9

[易语言] 易语言超级列表框导出xlsx源代码

[复制链接]

45

主题

46

帖子

142

积分

注册会员

Rank: 2

积分
142
发表于 2018-10-9 07:39:09 | 显示全部楼层 |阅读模式
易语言超级列表框导出xlsx源代码
最近在写软件需要用到导出xlsx,借鉴了论坛各位大佬的源码,但是总是差强人意,

易语言超级列表框导出xlsx源代码

易语言超级列表框导出xlsx源代码

  1. .版本 2
  2. .支持库 iext

  3. .子程序 _导出
  4. .局部变量 i, 整数型
  5. .局部变量 文件名, 文本型
  6. .局部变量 文件号, 整数型

  7. 文件名 = 到文本 (取现行时间 ())
  8. 文件_创建 (取运行目录 () + “\” + 文件名 + “.txt”, 0)
  9. 文件号 = 打开文件 (取运行目录 () + “\” + 文件名 + “.txt”, , )

  10. .计次循环首 (超级列表框1.取表项数 (), i)
  11.     写出文本 (文件号, 超级列表框1.取标题 (i - 1, 0) + 字符 (9) + 超级列表框1.取标题 (i - 1, 1) + 字符 (9) + 超级列表框1.取标题 (i - 1, 2) + 字符 (9) + 超级列表框1.取标题 (i - 1, 3) + 字符 (9) + 超级列表框1.取标题 (i - 1, 4) + #换行符)
  12. .计次循环尾 ()
  13. 关闭文件 (文件号)
  14. 文件更名 (取运行目录 () + “\” + 文件名 + “.txt”, 取运行目录 () + “\” + 文件名 + “.xlsx”)
  15. 信息框 (“导出完成”, 0, , )
复制代码
回复

使用道具 举报

0

主题

2075

帖子

4224

积分

论坛元老

Rank: 8Rank: 8

积分
4224
发表于 2018-10-15 10:34:07 | 显示全部楼层
慢性占有欲?
回复

使用道具 举报

0

主题

1853

帖子

3784

积分

论坛元老

Rank: 8Rank: 8

积分
3784
发表于 2018-11-4 10:31:51 | 显示全部楼层
人心向善,中国不散。
回复

使用道具 举报

0

主题

1716

帖子

3488

积分

论坛元老

Rank: 8Rank: 8

积分
3488
发表于 2018-11-6 15:34:46 | 显示全部楼层
美好的,留在心底;遗憾的,随风散去。
回复

使用道具 举报

0

主题

2236

帖子

4544

积分

论坛元老

Rank: 8Rank: 8

积分
4544
发表于 2018-11-8 16:51:39 | 显示全部楼层
带我走过最难忘的旅行,然后留下最痛的纪念品。
回复

使用道具 举报

0

主题

2645

帖子

5404

积分

论坛元老

Rank: 8Rank: 8

积分
5404
发表于 2018-11-13 10:52:28 | 显示全部楼层
一生一世想灌灌不牢
回复

使用道具 举报

0

主题

2604

帖子

5306

积分

论坛元老

Rank: 8Rank: 8

积分
5306
发表于 2018-11-15 13:21:41 | 显示全部楼层
没有不会干的事,只有不去干的人。
回复

使用道具 举报

26

主题

2961

帖子

6019

积分

论坛元老

Rank: 8Rank: 8

积分
6019
发表于 2018-12-31 18:46:36 | 显示全部楼层
让我对也好,让我错也好,随风灌灌论坛任逍遥……
回复

使用道具 举报

0

主题

3590

帖子

7246

积分

论坛元老

Rank: 8Rank: 8

积分
7246
发表于 2019-5-23 10:59:45 | 显示全部楼层
只有楼主这样具备广阔胸怀和完整知识体系的人,才能作为这真理的唯一引言者。
回复

使用道具 举报

0

主题

5

帖子

26

积分

新手上路

Rank: 1

积分
26
发表于 2020-9-16 20:17:43 | 显示全部楼层

美好的,留在心底;遗憾的,随风散去。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表