查看: 87|回复: 0

[易语言] 可以做自动更新的简单下载器源代码

[复制链接]

1674

主题

1675

帖子

5103

积分

论坛元老

Rank: 8Rank: 8

积分
5103
发表于 2019-5-15 20:04:05 | 显示全部楼层 |阅读模式
  1. .版本 2
  2. .支持库 downlib
  3. .支持库 spec

  4. .子程序 交互回调函数, 整数型
  5. .参数 消息类型, 整数型
  6. .参数 线程信息, 整数型
  7. .参数 未定义1, 整数型
  8. .参数 未定义2, 整数型
  9. .参数 对象信息, 整数型

  10. .判断开始 (消息类型 = #传送常量.下载上传开始)
  11.     进度条1.位置 = 0
  12.     文件总大小 = 未定义1
  13.     调试输出 (文件总大小)
  14.     调试输出 (“开始下载了”)
  15. .判断 (消息类型 = #传送常量.下载上传结束)
  16.     调试输出 (“下载结束了”)
  17. .判断 (消息类型 = #传送常量.收到数据)
  18.     标签1.标题 = 到文本 (数值到格式文本 (100 × 程序集_下载对象.取已下载长 () ÷ 文件总大小, 2, 假) + “%”)
  19.     进度条1.位置 = 取整 (100 × 程序集_下载对象.取已下载长 () ÷ 文件总大小)
  20. .默认

  21. .判断结束
  22. 返回 (0)
复制代码

可以做自动更新的简单下载器源代码

可以做自动更新的简单下载器源代码

简单的下载器自动更新.zip

198.51 KB, 下载次数: 2

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表