查看: 217|回复: 0

[易语言] 邮箱登录免码登录看收件箱小工具源码

[复制链接]

325

主题

325

帖子

989

积分

高级会员

Rank: 4

积分
989
发表于 2019-3-15 21:27:46 | 显示全部楼层 |阅读模式
  1. .版本 2
  2. .支持库 spec

  3. .子程序 子程序2
  4. .局部变量 js, 类_脚本组件
  5. .局部变量 加密密码, 文本型
  6. .局部变量 密码, 文本型
  7. .局部变量 提交数据, 文本型
  8. .局部变量 账号, 文本型
  9. .局部变量 文本, 文本型
  10. .局部变量 cookies, 文本型
  11. .局部变量 签到, 文本型
  12. .局部变量 cookies1, 文本型
  13. .局部变量 返回协议头, 文本型
  14. .局部变量 变量1, 文本型
  15. .局部变量 变量2, 文本型
  16. .局部变量 返回协议, 文本型
  17. .局部变量 sid, 文本型

  18. js.执行 (#网易js)
  19. 加密密码 = js.运行 (“test”, 密码)
  20. 调试输出 (加密密码, “加密后的密码”)
  21. 提交数据 = “method=login&back_url=&timestamp=0&m=1&register=0&wml=false&srandid=&ucid=&publicExponent=10001&modulus=967094d470dc7940f32ab7e8b701cf2ca732c7cd7aed176ecd8cac605da26e5fc8664382bb2c0b73b8a0109016130ff0c0f73985fa990a18466008b14284969d58f2c2c2698f91b6dcc6bebd90663d288dca79586b8294a56619dd87ab21274088c318e26b6e3210b165118b87ebc8798df572b2b84cfa9fe54d04e3b8dc1b25&username=” + 账号 + “&domain=163.com&password=” + 加密密码
  22. 调试输出 (提交数据)
  23. 文本 = 编码_utf8到gb2312 (到文本 (网页_访问_对象 (“http://m.mail.163.com/login.s”, 1, 提交数据, , cookies, #常量2, 返回协议头, , 真)))  ' --------登录163邮箱取cookies
  24. 调试输出 (cookies)
  25. 调试输出 (返回协议头)
  26. .如果 (寻找文本 (cookies, “NTES_SESS=”, , 假) ≠ -1)
  27.     调试输出 (账号 + “登陆成功!”)
  28. .否则
  29.     调试输出 (账号 + “登陆失败..”)
  30. .如果结束

  31. 变量1 = 文本_取出中间文本 (返回协议头, “mCookie=”, “&passport=”)
  32. 调试输出 (变量1, “mCookie”)
  33. 文本 = 到文本 (网页_访问_对象 (“http://m8.mm.mail.163.com/xm/mailbox.do?sid=HBHcNwvKhIkTmmlbqxKKGDlkEjCkpLAI&mCookie=” + 变量1 + “&wml=false&go=allMsgs&fid=1&keyfrom=allfolder”, 1, #常量1, cookies, ))  ' --------登录网易考拉取Gid+Did
  34. 文本 = 编码_URL解码 (文本, 真)
  35. 调试输出 (文本, “|文本”)
  36. sid = 文本_取出中间文本 (文本, “sid=”, “&amp”)
  37. 调试输出 (sid, “sid”)
  38. 变量2 = 编码_URL编码 (文本_取出中间文本 (文本, “value=” + #引号, #引号 + “ /”), 真)
  39. 调试输出 (变量2, “value”)
  40. 文本 = 到文本 (网页_访问_对象 (“http://m8.mm.mail.163.com/xm/message.do?&wml=false&go=curMsg&fparam=1%3B1%3Bfalse&mid=” + 变量2 + “&index=0&read=true&isEncrypted=0&sid=” + sid + “&mCookie=” + 变量1 + “&keyfrom=error”, 1, #常量1, cookies, ))  ' --------登录网易考拉取Gid+Did
  41. 文本 = 编码_URL解码 (文本, 真)
  42. 调试输出 (文本, “|文本”)
复制代码

邮箱登录免码登录看收件箱小工具源码

邮箱登录免码登录看收件箱小工具源码

邮箱登录查看邮箱.zip

215.43 KB, 下载次数: 4

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表