查看: 269|回复: 1

[易语言] 开源简单的企业ERP管理系统源代码

[复制链接]

106

主题

106

帖子

329

积分

中级会员

Rank: 3Rank: 3

积分
329
发表于 2019-3-14 22:20:12 | 显示全部楼层 |阅读模式
  1. .版本 2
  2. .支持库 dp1
  3. .支持库 eAPI

  4. .子程序 材料_添加预定值
  5. .局部变量 局部_材料单位行号, 整数型
  6. .局部变量 局部_材料单位句柄, 整数型
  7. .局部变量 局部_类别, 文本型
  8. .局部变量 局部_类别行号, 整数型
  9. .局部变量 局部_类别句柄, 整数型
  10. .局部变量 局部_单位, 文本型

  11. .如果 (编辑框_材料编号.内容 = “”)
  12.     局部_材料单位行号 = 0
  13.     局部_材料单位句柄 = 全局_数据库.查询 (“select * from 系统基本信息管理模块”)
  14.     全局_数据库.到首记录 (局部_材料单位句柄)
  15.     .判断循环首 (全局_数据库.尾记录后 (局部_材料单位句柄) = 假)
  16.         局部_单位 = 全局_数据库.读 (局部_材料单位句柄, “默认单位”)
  17.         组合框_默认单位.加入项目 (局部_单位, 局部_材料单位行号)
  18.         组合框_第二单位.加入项目 (局部_单位, 局部_材料单位行号)
  19.         全局_数据库.到后一记录 (局部_材料单位句柄)
  20.         局部_材料单位行号 = 局部_材料单位行号 + 1
  21.     .判断循环尾 ()
  22.     局部_用户行号 = 0
  23.     局部_类别句柄 = 全局_数据库.查询 (“select * from 材料类别表”)
  24.     全局_数据库.到首记录 (局部_类别句柄)
  25.     .判断循环首 (全局_数据库.尾记录后 (局部_类别句柄) = 假)
  26.         局部_类别 = 全局_数据库.读 (局部_类别句柄, “材料类别”)
  27.         组合框_材料类别.加入项目 (局部_类别, 局部_类别行号)
  28.         全局_数据库.到后一记录 (局部_类别句柄)
  29.         局部_类别行号 = 局部_类别行号 + 1
  30.     .判断循环尾 ()
  31. .否则

  32. .如果结束
  33. 编辑框_材料编号.内容 = “CL000000”
  34. 连续赋值 (“”, 编辑框_材料名称.内容, 编辑框_安全库存.内容, 编辑框_材料备注.内容, 编辑框_换算率.内容)
  35. 编辑框_期初库存.内容 = “0”

  36. .子程序 校验
  37. .局部变量 软件次数, 整数型
  38. .局部变量 局部_验证句柄, 整数型
  39. .局部变量 局部_次数句柄, 整数型

  40. 校验码 = 取数据摘要 (到字节集 (取本机网卡物理地址 () + 到文本 (取硬盘特征字 ()) + “8”))
  41. 局部_验证句柄 = 全局_数据库.查询 (“select * from 验证码 where 验证='” + 校验码 + “'”)
  42. 校验_结果 = 全局_数据库.读 (局部_验证句柄, “验证”)
  43. .如果 (校验_结果 ≠ 校验码)
  44.     局部_次数句柄 = 全局_数据库.查询 (“select * from 使用次数”)
  45.     软件次数 = 到数值 (全局_数据库.读 (局部_次数句柄, “次数”))
  46.     全局_数据库.执行 (“UPDATE 使用次数 SET 次数 ='” + 到文本 (软件次数 - 1) + “'”, )
  47.     .如果 (软件次数 > 3)
  48.         信息框 (“你没有获得软件的使用授权,请把此机器识别号发给您的软件提供商获取注册码!” + #换行符 + 到文本 (取硬盘特征字 ()) + 取本机网卡物理地址 () + #换行符 + “您对本软件的使用权限还有:” + 到文本 (软件次数) + “次!” + “本软件由独行侍卫开发,联系邮箱为fjssfj@qq.com”, 32, “提示”)
  49.         载入 (登录窗口, _启动窗口, 真)
  50.     .否则
  51.         信息框 (“你没有获得软件的使用授权,请把此机器识别号发给您的软件提供商获取注册码!” + #换行符 + 到文本 (取硬盘特征字 ()) + 取本机网卡物理地址 () + #换行符 + “您对本软件的使用权限还有:” + 到文本 (软件次数) + “次!” + “本软件由独行侍卫开发,联系邮箱为fjssfj@qq.com”, 32, “提示”)
  52.         全局_数据库.关闭 ()
  53.         销毁 ()
  54.     .如果结束

  55. .否则
  56.     载入 (登录窗口, _启动窗口, 真)
复制代码

开源简单的企业ERP管理系统源代码

开源简单的企业ERP管理系统源代码

简单ERP管理系统.rar

585.67 KB, 下载次数: 4

回复

使用道具 举报

0

主题

2

帖子

10

积分

新手上路

Rank: 1

积分
10
发表于 2019-3-15 11:26:43 | 显示全部楼层
抢个沙发,下载学习
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表