查看: 45|回复: 0

[易语言] 利用乐玩模块识别网站加减法验证码源码

[复制链接]

217

主题

217

帖子

661

积分

高级会员

Rank: 4

积分
661
发表于 2019-3-13 09:14:33 | 显示全部楼层 |阅读模式

本帖子中包含更多资源,您需要登录才可以下载或查看更多内容!

您需要 登录 才可以下载附件,没有帐号?注册账号入驻无名

利用乐玩模块识别网站加减法验证码源码

利用乐玩模块识别网站加减法验证码源码

  1. .版本 2
  2. .支持库 spec

  3. .子程序 _按钮_识别_被单击
  4. .局部变量 左边文本, 文本型
  5. .局部变量 右边文本, 文本型

  6. .如果真 (图片框1.图片 ≠ {  })
  7.     编辑框1.内容 = lw.文字_识字数据 (图片框1.图片, “#134”, 0.95, , 假)
  8.     .如果真 (编辑框1.内容 ≠ “”)
  9.         .如果 (寻找文本 (编辑框1.内容, “+”, , 假) ≠ -1)
  10.             左边文本 = 文本_取左边 (编辑框1.内容, “+”)
  11.             右边文本 = 文本_取出中间文本 (编辑框1.内容, “+”, “=”)
  12.             编辑框_结果.内容 = 到文本 (到整数 (左边文本) + 到整数 (右边文本))
  13.         .否则
  14.             左边文本 = 文本_取左边 (编辑框1.内容, “-”)
  15.             右边文本 = 文本_取出中间文本 (编辑框1.内容, “-”, “=”)
  16.             编辑框_结果.内容 = 到文本 (到整数 (左边文本) - 到整数 (右边文本))
  17.         .如果结束

  18.     .如果真结束

  19. .如果真结束


  20. .子程序 __启动窗口_创建完毕

  21. 调试输出 (lw.文字_置字库 (0, “C:\Users\Administrator\Desktop\驾校网站验证码识别\默认字库.txt”))
复制代码

网站验证码识别.zip

312.21 KB, 下载次数: 3

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表