查看: 51|回复: 0

[易语言] 单线程实现类似多线程的功能源码

[复制链接]

217

主题

217

帖子

661

积分

高级会员

Rank: 4

积分
661
发表于 2019-3-12 20:28:19 | 显示全部楼层 |阅读模式

本帖子中包含更多资源,您需要登录才可以下载或查看更多内容!

您需要 登录 才可以下载附件,没有帐号?注册账号入驻无名

单线程实现类似多线程的功能源码

单线程实现类似多线程的功能源码

  1. .版本 2
  2. .支持库 iext
  3. .支持库 spec

  4. .子程序 私信总线程
  5. .局部变量 a_1, 整数型
  6. .局部变量 a_2, 整数型
  7. .局部变量 a_4, 整数型

  8. ' 根据线程数取出账号cookie
  9. .计次循环首 (线程数量, a_1)  ' 根据线程数量 同时讲满足账号的cookie写入数组

  10.     .计次循环首 (账号总数, a_2)
  11.         .如果 (到整数 (超级列表框1.取标题 (a_2 - 1, 2)) < 私信条数)
  12.             加入成员 (cookie组, 超级列表框1.取标题 (a_2 - 1, 1))  ' 将符合条件的账号cookie写入数组。取出来,数量未必等于线程数
  13.             .如果 (取数组成员数 (cookie组) = 线程数量)
  14.                 跳出循环 ()

  15.             .否则

  16.             .如果结束

  17.         .否则

  18.         .如果结束

  19.     .计次循环尾 ()
  20.     .如果 (取数组成员数 (cookie组) = 线程数量)
  21.         跳出循环 ()

  22.     .否则

  23.     .如果结束

  24. .计次循环尾 ()
  25. ' 根据线程数取出吧满足条件的用户id,取出来,数量未必等于线程数
  26. .计次循环首 (用户id总数, a_4)
  27.     .如果 (到整数 (超级列表框2.取标题 (a_4 - 1, 3)) < 私信条数)
  28.         加入成员 (用户id组, 超级列表框2.取标题 (a_4 - 1, 1))  ' 将符合条件的用户id写入数组。取出来,数量未必等于线程数,吧他等于上面的账号数组数量
  29.         .如果 (取数组成员数 (用户id组) = 取数组成员数 (cookie组))
  30.             跳出循环 ()

  31.         .否则

  32.         .如果结束

  33.     .否则

  34.     .如果结束

  35.     .如果 (取数组成员数 (用户id组) = 取数组成员数 (cookie组))
  36.         跳出循环 ()

  37.     .否则

  38.     .如果结束

  39. .计次循环尾 ()
  40. 调试输出 (“用户id组数量” + 到文本 (取数组成员数 (用户id组)))
  41. 调试输出 (“cookie组数量” + 到文本 (取数组成员数 (cookie组)))
  42. 私信_线程 ()

  43. .子程序 私信_线程
  44. .局部变量 a_3, 整数型
  45. .局部变量 cookies, 文本型
  46. .局部变量 a_5, 整数型
  47. .局部变量 a_6, 整数型
  48. .局部变量 用户id, 文本型
  49. .局部变量 私信结果, 文本型
  50. .局部变量 a_7, 整数型

  51. ' 取话术内容
  52. .计次循环首 (私信条数, a_3)
  53.     .如果 (a_3 = 1)
  54.         话术 = “1”
  55.     .否则
  56.         .如果 (a_3 = 2)
  57.             话术 = “2”
  58.         .否则
  59.             .如果 (a_3 = 3)
  60.                 话术 = “3”
  61.             .否则

  62.             .如果结束

  63.         .如果结束

  64.     .如果结束
  65.     调试输出 (“cookie组数量” + 到文本 (取数组成员数 (cookie组)))
  66.     调试输出 (“用户id组数量” + 到文本 (取数组成员数 (用户id组)))
  67.     .计次循环首 (取数组成员数 (cookie组), a_5)
  68.         cookies = cookie组 [a_5]
  69.         用户id = cookie组 [a_5]
  70.         私信结果 = 私信 (话术, cookies, 用户id)
  71.         .如果 (私信结果 = “成功”)

  72.             .计次循环首 (用户id总数, a_6)
  73.                 .如果 (到整数 (超级列表框2.取标题 (a_6 - 1, 3)) < 私信条数)
  74.                     超级列表框2.置标题 (a_6 - 1, 2, “成功”)
  75.                     超级列表框2.置标题 (a_6 - 1, 3, 到文本 (到整数 (超级列表框2.取标题 (a_6 - 1, 3)) + 1))

  76.                 .否则

  77.                 .如果结束

  78.             .计次循环尾 ()

  79.             .计次循环首 (账号总数, a_7)
  80.                 .如果 (到整数 (超级列表框1.取标题 (a_7 - 1, 2)) < 私信条数)
  81.                     超级列表框1.置标题 (a_7 - 1, 2, 到文本 (到整数 (超级列表框1.取标题 (a_7 - 1, 2)) + 1))

  82.                 .否则

  83.                 .如果结束

  84.             .计次循环尾 ()

  85.         .否则

  86.         .如果结束
  87.         ' 延时 (3000)
  88.     .计次循环尾 ()
  89. .计次循环尾 ()
  90. 信息框 (“完成”, 0, , )
复制代码

单线程实现多线程功能案例.rar

174.35 KB, 下载次数: 0

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表