查看: 175|回复: 0

[易语言] 拖放文本到超级列表框及自动识别姓名 手机号等信息

[复制链接]

217

主题

217

帖子

661

积分

高级会员

Rank: 4

积分
661
发表于 2019-3-12 20:26:19 | 显示全部楼层 |阅读模式
拖放文本到超级列表框及自动识别姓名 手机号等信息 至于你们怎么调用就看你们了
希望撸界的大佬都加上,我以后就不用改文本格式了。
校检是用的别人的一个源码

拖放文本到超级列表框及自动识别姓名 手机号等信息

拖放文本到超级列表框及自动识别姓名 手机号等信息

  1. .版本 2

  2. .子程序 卡号校验, 逻辑型, , 一般都是19位
  3. .参数 卡号, 文本型
  4. .局部变量 m, 整数型, , "10"
  5. .局部变量 i, 整数型
  6. .局部变量 digit, 整数型
  7. .局部变量 sum, 整数型
  8. .局部变量 odd, 整数型

  9. m [1] = 0
  10. m [2] = 2
  11. m [3] = 4
  12. m [4] = 6
  13. m [5] = 8
  14. m [6] = 1
  15. m [7] = 3
  16. m [8] = 5
  17. m [9] = 7
  18. m [10] = 9
  19. odd = 1
  20. .变量循环首 (取文本长度 (卡号), 1, -1, i)
  21.     digit = 取代码 (卡号, i) - 48
  22.     sum = sum + 选择 (odd ≠ 0, digit, m [digit + 1])
  23.     .如果 (odd = 1)
  24.         odd = 0
  25.     .否则
  26.         odd = 1
  27.     .如果结束

  28. .变量循环尾 ()
  29. ' const int m[] = {0,2,4,6,8,1,3,5,7,9}; // mapping for rule 3
  30. ' int i, odd = 1, sum = 0;

  31. ' for (i = strlen(cc); i=i-1; odd = !odd)
  32. ' {
  33. ' int digit = cc[i] - '0';
  34. ' sum =sum+ odd ? digit : m[digit];
  35. ' }
  36. 返回 (sum % 10 = 0)
复制代码

自动识别信息.rar

183.56 KB, 下载次数: 1

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表