查看: 95|回复: 1

[易语言] 百合网引流工具自动注册和采集私信源码

[复制链接]

342

主题

342

帖子

1049

积分

金牌会员

Rank: 6Rank: 6

积分
1049
发表于 2019-3-8 09:29:08 | 显示全部楼层 |阅读模式

本帖子中包含更多资源,您需要登录才可以下载或查看更多内容!

您需要 登录 才可以下载附件,没有帐号?注册账号入驻无名

  1. .版本 2
  2. .支持库 iext
  3. .支持库 spec
  4. .支持库 internet

  5. .子程序 采集数据
  6. .局部变量 str采集, 文本型
  7. .局部变量 数据, 正则表达式类
  8. .局部变量 i, 整数型
  9. .局部变量 文本id, 文本型
  10. .局部变量 文本, 文本型
  11. .局部变量 文本处理, 文本型
  12. .局部变量 访问采集str, 文本型
  13. .局部变量 数据采集, 正则表达式类
  14. .局部变量 a, 整数型
  15. .局部变量 k, 整数型
  16. .局部变量 str修改, 文本型
  17. .局部变量 str发送, 文本型
  18. .局部变量 n, 整数型

  19. 超级列表框3.全部删除 ()
  20. str修改 = 编码_usc2到ansi (到文本 (网页_访问_对象 (“http://my.baihe.com/Userinfo/subBasicInfo?jsonCallBack=jQuery18304226343745899077_1531459599834&nickname=” + 名字 + “&birthday=” + 年月 + “&height=” + 身高 + “&education=” + education + “&occupation=” + occupation + “&marriage=” + marriage + “&children=1&district=” + 城市序号 + “&homeDistrict=86&income=” + income + “&housing=” + housing + “&car=&mobileContact=&phoneContact=&weiXinContact=&qqContact=&otherContact=&_=1531459872399”, , , cookies)))
  21. 调试输出 (str修改)
  22. 日记记录.加入文本 (str修改 + “执行采集中”)
  23. .如果真 (组合框1.现行选中项 = 0)
  24.     str采集 = 编码_URL解码UTF8 (到文本 (网页_访问_对象 (“http://search.baihe.com/Search/getUserID?&jsonCallBack=jQuery183019102162931514433_1531408218381 ”, 1, “minAge=” + 编辑框1.内容 + “&maxAge=” + 编辑框2.内容 + “&minHeight=” + 编辑框6.内容 + “&maxHeight=” + 编辑框7.内容 + “&education=1-8&loveType=&marriage=&income=6-6&city=” + 城市序号 + “&nationality=&occupation=&children=&bloodType=&constellation=&religion=&online=&isPayUser=&isCreditedByAuth=&hasPhoto=1&housing=&car=&homeDistrict=&page=1&sorterField=3”, cookies, , #采集UA)))
  25. .如果真结束
  26. .如果真 (组合框1.现行选中项 = 1)
  27.     str采集 = 编码_URL解码UTF8 (到文本 (网页_访问_对象 (“http://search.baihe.com/Search/getUserID?&jsonCallBack=jQuery183019102162931514433_1531408218381 ”, 1, “minAge=” + 编辑框1.内容 + “&maxAge=” + 编辑框2.内容 + “&minHeight=” + 编辑框6.内容 + “&maxHeight=” + 编辑框7.内容 + “&education=1-8&loveType=&marriage=&income=6-6&city=” + 城市序号 + “&nationality=&occupation=&children=&bloodType=&constellation=&religion=&online=&isPayUser=&isCreditedByAuth=&hasPhoto=1&housing=&car=&homeDistrict=&page=1&sorterField=2”, cookies, , #采集UA)))
  28. .如果真结束
  29. .如果真 (组合框1.现行选中项 = 2)
  30.     str采集 = 编码_URL解码UTF8 (到文本 (网页_访问_对象 (“http://search.baihe.com/Search/getUserID?&jsonCallBack=jQuery183019102162931514433_1531408218381 ”, 1, “minAge=” + 编辑框1.内容 + “&maxAge=” + 编辑框2.内容 + “&minHeight=” + 编辑框6.内容 + “&maxHeight=” + 编辑框7.内容 + “&education=1-8&loveType=&marriage=&income=6-6&city=” + 城市序号 + “&nationality=&occupation=&children=&bloodType=&constellation=&religion=&online=&isPayUser=&isCreditedByAuth=&hasPhoto=1&housing=&car=&homeDistrict=&page=1&sorterField=4”, cookies, , #采集UA)))
  31. .如果真结束
  32. .如果真 (组合框1.现行选中项 = 3)
  33.     str采集 = 编码_URL解码UTF8 (到文本 (网页_访问_对象 (“http://search.baihe.com/Search/getUserID?&jsonCallBack=jQuery183019102162931514433_1531408218381 ”, 1, “minAge=” + 编辑框1.内容 + “&maxAge=” + 编辑框2.内容 + “&minHeight=” + 编辑框6.内容 + “&maxHeight=” + 编辑框7.内容 + “&education=1-8&loveType=&marriage=&income=6-6&city=” + 城市序号 + “&nationality=&occupation=&children=&bloodType=&constellation=&religion=&online=&isPayUser=&isCreditedByAuth=&hasPhoto=1&housing=&car=&homeDistrict=&page=1&sorterField=5”, cookies, , #采集UA)))
  34. .如果真结束
  35. .如果真 (组合框1.现行选中项 = 4)
  36.     str采集 = 编码_URL解码UTF8 (到文本 (网页_访问_对象 (“http://search.baihe.com/Search/getUserID?&jsonCallBack=jQuery183019102162931514433_1531408218381 ”, 1, “minAge=” + 编辑框1.内容 + “&maxAge=” + 编辑框2.内容 + “&minHeight=” + 编辑框6.内容 + “&maxHeight=” + 编辑框7.内容 + “&education=1-8&loveType=&marriage=&income=6-6&city=” + 城市序号 + “&nationality=&occupation=&children=&bloodType=&constellation=&religion=&online=&isPayUser=&isCreditedByAuth=&hasPhoto=1&housing=&car=&homeDistrict=&page=1&sorterField=6”, cookies, , #采集UA)))
  37. .如果真结束
  38. .如果真 (组合框1.现行选中项 = 5)
  39.     str采集 = 编码_URL解码UTF8 (到文本 (网页_访问_对象 (“http://search.baihe.com/Search/getUserID?&jsonCallBack=jQuery183019102162931514433_1531408218381 ”, 1, “minAge=” + 编辑框1.内容 + “&maxAge=” + 编辑框2.内容 + “&minHeight=” + 编辑框6.内容 + “&maxHeight=” + 编辑框7.内容 + “&education=1-8&loveType=&marriage=&income=6-6&city=” + 城市序号 + “&nationality=&occupation=&children=&bloodType=&constellation=&religion=&online=&isPayUser=&isCreditedByAuth=&hasPhoto=1&housing=&car=&homeDistrict=&page=1&sorterField=7”, cookies, , #采集UA)))
  40. .如果真结束

  41. 文本id = 文本_取出中间文本 (str采集, #常量1, #常量2)
  42. 文本id = “-” + 文本id + “-”
  43. 文本id = 文本_替换 (文本id, , , , #常量3, “-”)
  44. 文本 = 文本id
  45. 数据.创建 (“-(.*?)-”, 文本id)
  46. .计次循环首 (数据.取匹配数量 (), i)
  47.     文本id = 数据.取子匹配文本 (i, 1)
  48.     调试输出 (文本id)
  49.     日记记录.加入文本 (文本id)
  50.     访问采集str = 编码_usc2到ansi (到文本 (网页_访问_对象 (“http://search.baihe.com/search/getUserList?userIDs=” + 文本id + “&jsonCallBack=jQuery183019102162931514433_1531408218382”, 1, “userIDs=” + 文本id + “&jsonCallBack=jQuery183019102162931514433_1531408218382”, cookies)))
  51.     调试输出 (访问采集str)
  52.     日记记录.加入文本 (访问采集str)
  53.     k = 超级列表框3.插入表项 (, , , , , )
  54.     h = h + 1
  55.     数据采集.创建 (#采集数据, 访问采集str)
  56.     .计次循环首 (数据采集.取匹配数量 (), a)
  57.         超级列表框3.置标题 (k, 0, 到文本 (h))
  58.         超级列表框3.置标题 (k, 1, 数据采集.取子匹配文本 (a, 1))
  59.         超级列表框3.置标题 (k, 2, 数据采集.取子匹配文本 (a, 2))
  60.         超级列表框3.置标题 (k, 3, 数据采集.取子匹配文本 (a, 3))
  61.         n = 超级列表框2.插入表项 (, , , , , )
  62.         b = b + 1
  63.         str发送 = 编码_usc2到ansi (到文本 (网页_访问_对象 (“http://msg.baihe.com/owner/api/sendMessage?jsonCallBack=jQuery1830253684304419564_1531460755599&toUserID=” + 文本id + “&content=” + 编码_URL编码UTF8 (编辑框5.内容, 真) + “&type=1&pathID=01.00.10402&_=1531460792265”, , , cookies)))
  64.         调试输出 (str发送)
  65.         日记记录.加入文本 (str发送)
  66.         超级列表框2.置标题 (n, 0, 到文本 (b))
  67.         超级列表框2.置标题 (n, 1, 文本id)
  68.         超级列表框2.置标题 (n, 2, 编辑框5.内容)
  69.         .如果 (寻找文本 (str发送, #发送信息成功, , 假) ≠ -1)
  70.             超级列表框2.置标题 (n, 3, “发送成功”)
  71.             发送成功 = 发送成功 + 1
  72.             日记记录.加入文本 (“账号:” + 账号 + “已发送:” + 到文本 (发送成功) + #换行符)
  73.         .否则
  74.             超级列表框2.置标题 (n, 3, “发送失败”)
  75.         .如果结束

  76.         .如果真 (寻找文本 (str发送, “今天发起的会话数量”, , 假) ≠ -1)
  77.             跳出循环 ()
  78.         .如果真结束
  79.         .如果真 (寻找文本 (str发送, #没有实名, , 假) ≠ -1)
  80.             日记记录.加入文本 (“账号:” + 账号 + “请实名认证” + #换行符)
  81.             跳出循环 ()
  82.         .如果真结束
  83.         .如果真 (寻找文本 (str发送, #没有手机认证, , 假) ≠ -1)
  84.             日记记录.加入文本 (“账号:” + 账号 + “请手机认证” + #换行符)
  85.             跳出循环 ()
  86.         .如果真结束
  87.         .如果真 (寻找文本 (str发送, #对方异地, , 假) ≠ -1)
  88.             日记记录.加入文本 (“账号:” + 账号 + “对方异地用户” + #换行符)
  89.             跳出循环 ()
  90.         .如果真结束
  91.         程序_延时 (到整数 (编辑框4.内容))
  92.         程序_延时 (10)
  93.     .计次循环尾 ()
  94.     文本处理 = 文本_替换 (文本, 1, , , 文本id, “x”)
  95.     程序_延时 (100)
  96. .计次循环尾 ()
  97. 文本id = 文本_取出中间文本 (文本处理, “-x-”, “-”)
  98. 调试输出 (文本id)
  99. 访问采集str = 编码_usc2到ansi (到文本 (网页_访问_对象 (“http://search.baihe.com/search/getUserList?userIDs=” + 文本id + “&jsonCallBack=jQuery183019102162931514433_1531408218382”, 1, “userIDs=” + 文本id + “&jsonCallBack=jQuery183019102162931514433_1531408218382”, cookies)))
  100. 调试输出 (访问采集str)
  101. k = 超级列表框3.插入表项 (, , , , , )
  102. h = h + 1
  103. 数据采集.创建 (#采集数据, 访问采集str)
  104. .计次循环首 (数据采集.取匹配数量 (), a)
  105.     超级列表框3.置标题 (k, 0, 到文本 (h))
  106.     超级列表框3.置标题 (k, 1, 数据采集.取子匹配文本 (a, 1))
  107.     超级列表框3.置标题 (k, 2, 数据采集.取子匹配文本 (a, 2))
  108.     超级列表框3.置标题 (k, 3, 数据采集.取子匹配文本 (a, 3))
  109.     n = 超级列表框2.插入表项 (, , , , , )
  110.     b = b + 1
  111.     str发送 = 编码_usc2到ansi (到文本 (网页_访问_对象 (“http://msg.baihe.com/owner/api/sendMessage?jsonCallBack=jQuery1830253684304419564_1531460755599&toUserID=” + 文本id + “&content=” + 编码_URL编码UTF8 (编辑框5.内容, 真) + “&type=1&pathID=01.00.10402&_=1531460792265”, , , cookies)))
  112.     调试输出 (str发送)
  113.     超级列表框2.置标题 (n, 0, 到文本 (b))
  114.     超级列表框2.置标题 (n, 1, 文本id)
  115.     超级列表框2.置标题 (n, 2, 编辑框5.内容)
  116.     .如果 (寻找文本 (str发送, #发送信息成功, , 假) ≠ -1)
  117.         超级列表框2.置标题 (n, 3, “发送成功”)
  118.         发送成功 = 发送成功 + 1
  119.         日记记录.加入文本 (“账号:” + 账号 + “已发送:” + 到文本 (发送成功) + #换行符)
  120.     .否则
  121.         超级列表框2.置标题 (n, 3, “发送失败”)
  122.     .如果结束
  123.     .如果真 (寻找文本 (str发送, “今天发起的会话数量”, , 假) ≠ -1)
  124.         跳出循环 ()
  125.     .如果真结束
  126.     .如果真 (寻找文本 (str发送, #没有实名, , 假) ≠ -1)
  127.         日记记录.加入文本 (“账号:” + 账号 + “请实名认证” + #换行符)
  128.         跳出循环 ()
  129.     .如果真结束
  130.     .如果真 (寻找文本 (str发送, #没有手机认证, , 假) ≠ -1)
  131.         日记记录.加入文本 (“账号:” + 账号 + “请手机认证” + #换行符)
  132.         跳出循环 ()
  133.     .如果真结束
  134.     .如果真 (寻找文本 (str发送, #对方异地, , 假) ≠ -1)
  135.         日记记录.加入文本 (“账号:” + 账号 + “对方异地用户” + #换行符)
  136.         跳出循环 ()
  137.     .如果真结束
  138.     程序_延时 (到整数 (编辑框4.内容))
  139. .计次循环尾 ()
  140. .如果真 (选择框1.选中 = 真)
  141.     城市选择 = 城市选择 + 1
  142.     组合框2.现行选中项 = 城市选择
  143.     城市序号 = 组合框2.取项目文本 (组合框2.现行选中项)
  144.     城市序号 = 文本_取出中间文本 (城市序号, “-”, “-”)
  145.     调试输出 (城市序号)
  146. .如果真结束

  147. .如果真 (寻找文本 (str发送, “今天发起的会话数量已经超过”, , 假) ≠ -1)
  148.     b = 0
  149.     h = 0
  150.     日记记录.加入文本 (“账号:” + 账号 + “已经达到数量!” + #换行符)
  151.     线程_恢复 (句柄)
  152. .如果真结束

  153. .如果 (是否已在线 () = 假)
  154.     挂断 ()
  155.     程序_延时 (3000)
  156.     拨号 (“@0”, 编辑框_宽带用户名.内容, 编辑框_宽带密码.内容, 真, )
  157. .否则
  158.     挂断 ()
  159.     程序_延时 (3000)
  160.     拨号 (“@0”, 编辑框_宽带用户名.内容, 编辑框_宽带密码.内容, 真, )
  161. .如果结束
  162. 线程_恢复 (句柄)
复制代码

百合网引流工具自动注册和采集私信源码

百合网引流工具自动注册和采集私信源码

百合私信源码.rar

319.93 KB, 下载次数: 10

回复

使用道具 举报

0

主题

5

帖子

22

积分

新手上路

Rank: 1

积分
22
QQ
发表于 2019-3-15 20:36:54 | 显示全部楼层
谁拿了源码做了成品出来的 卖给我用用   +921655777
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表