查看: 374|回复: 0

[易语言] PC微信内存搜索群目录好友目录工具源码待优化版

[复制链接]

189

主题

189

帖子

584

积分

高级会员

Rank: 4

积分
584
发表于 2019-2-12 19:43:17 | 显示全部楼层 |阅读模式

微信内存搜索群目录好友目录工具源码待优化版

微信内存搜索群目录好友目录工具源码待优化版

  1. .版本 2
  2. .支持库 spec
  3. .支持库 iext

  4. .子程序 _按钮2_被单击
  5. .局部变量 sz, 整数型, , "0"
  6. .局部变量 内存, 类_内存
  7. .局部变量 i, 整数型
  8. .局部变量 bx, 整数型
  9. .局部变量 内容, 文本型, , "3"
  10. .局部变量 循环, 整数型

  11. 编辑框3.内容 = “”
  12. 进程_取ID数组 (“WeChat.exe”, 进程id)
  13. 内存.搜索 (进程id [1], 到字节集 (“wxid_”), sz)
  14. 循环 = 取数组成员数 (sz)
  15. 调试输出 (循环)
  16. .计次循环首 (1000, i)
  17.     处理事件 ()
  18.     内容 [1] = 内存.读文本 (进程id [1], sz [i], 1000)
  19.     ' 内容 [2] = 内存.读文本 (进程id [1], sz [i] + 19, 500)
  20.     编辑框3.加入文本 (内容 [1] + #换行符)
  21.     ' 编辑框4.加入文本 (内容 [2] + #换行符)
  22.     到循环尾 ()
  23.     .如果真 (寻找文本 (内容 [2], “ttp”, , 假) ≠ -1)
  24.         到循环尾 ()
  25.     .如果真结束
  26.     bx = 超级列表框1.插入表项 (, 到文本 (超级列表框1.取表项数 () + 1), , , , )
  27.     超级列表框1.置标题 (bx, 1, 内存.读文本 (进程id [1], sz [i], 200))
  28.     .如果真 (寻找文本 (内容 [2], “v1_”, , 假) ≠ -1)
  29.         .如果 (取文本左边 (内容 [2], 寻找文本 (内容 [2], “v1_”, , 假) - 1) ≠ “”)
  30.             超级列表框1.置标题 (bx, 2, 取文本左边 (内容 [2], 寻找文本 (内容 [2], “v1_”, , 假) - 1))
  31.         .否则

  32.         .如果结束
  33.         超级列表框1.置标题 (bx, 3, “v1_” + 文本_取出中间文本 (内容 [2], “v1_”, “@”, , ))
  34.     .如果真结束

  35. .计次循环尾 ()

  36. .子程序 子程序, 整数型
  37. .参数 进程, 整数型
  38. .参数 地址, 整数型
  39. .局部变量 内存, 类_内存
  40. .局部变量 n, 文本型

  41. .计次循环首 (50, x)
  42.     n = 内存.读文本 (进程, 地址 - x, 100)
  43.     .如果真 (取文本左边 (n, 5) = “wxid_” 或 取文本左边 (n, 3) = “gh_”)
  44.         返回 (x)
  45.     .如果真结束

  46. .计次循环尾 ()
  47. 返回 (0)

  48. .子程序 __启动窗口_首次激活
  49. .局部变量 sz, 整数型, , "0"
  50. .局部变量 i, 整数型
  51. .局部变量 bx, 整数型
  52. .局部变量 内存, 类_内存
  53. .局部变量 内容, 文本型, , "3"
  54. .局部变量 a, 文本型
  55. .局部变量 b, 文本型

  56. 进程_取ID数组 (“WeChat.exe”, 进程id)
  57. 输出调试文本 (“首次激活 ” + 到文本 (取数组成员数 (进程id)))
  58. 内存.搜索 (进程id [1], 到字节集 (“v1_”), sz)
  59. .计次循环首 (取数组成员数 (sz), i)
  60.     内容 [1] = 编码_URL解码 (内存.读文本 (进程id [1], sz [i] - 子程序 (进程id [1], sz [i]), 200), 真)
  61.     .如果真 (寻找文本 (内容 [1], “http”, , 假) = -1 或 超级列表框1.查找表项 (内容 [1], , , 5) ≠ -1)
  62.         到循环尾 ()
  63.     .如果真结束

  64.     bx = 超级列表框1.插入表项 (, 到文本 (超级列表框1.取表项数 () + 1), , , , )
  65.     超级列表框1.置标题 (bx, 5, 内容 [1])
  66.     .如果真 (取文本左边 (内容 [1], 5) = “wxid_”)
  67.         超级列表框1.置标题 (bx, 1, 取文本左边 (内容 [1], 19))
  68.         内容 [1] = 取文本右边 (内容 [1], 取文本长度 (内容 [1]) - 19)
  69.     .如果真结束

  70.     .如果真 (取文本左边 (内容 [1], 3) = “gh_”)
  71.         超级列表框1.置标题 (bx, 1, 取文本左边 (内容 [1], 15))
  72.         内容 [1] = 取文本右边 (内容 [1], 取文本长度 (内容 [1]) - 15)
  73.     .如果真结束

  74.     超级列表框1.置标题 (bx, 2, 取文本左边 (内容 [1], 寻找文本 (内容 [1], “v1_”, , 假) - 1))
  75.     内容 [1] = 取文本右边 (内容 [1], 取文本长度 (内容 [1]) - 倒找文本 (内容 [1], “v1_”, , 假) + 1)
  76.     超级列表框1.置标题 (bx, 3, 取文本左边 (内容 [1], 寻找文本 (内容 [1], “@stranger”, , 假) - 1))
  77.     超级列表框1.置标题 (bx, 4, 文本_取出中间文本 (内容 [1], “@stranger”, “http”, , ))
  78. .计次循环尾 ()
复制代码

微信内存搜索群目录好友目录.rar

143.16 KB, 下载次数: 0

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表