查看: 308|回复: 0

[易语言] 猫眼电影数据实时在线采集软件源码

[复制链接]

189

主题

189

帖子

584

积分

高级会员

Rank: 4

积分
584
发表于 2019-2-12 19:41:17 | 显示全部楼层 |阅读模式
猫眼电影数据实时在线采集软件源码 直接复制粘贴就能用了非常简单

猫眼电影数据实时在线采集软件源码

猫眼电影数据实时在线采集软件源码

  1. .版本 2
  2. .支持库 iext

  3. .子程序 电影票房
  4. .局部变量 i, 文本型
  5. .局部变量 i1, 文本型
  6. .局部变量 i2, 整数型
  7. .局部变量 i3, 文本型
  8. .局部变量 i4, 类_json
  9. .局部变量 i5, 文本型
  10. .局部变量 i6, 文本型
  11. .局部变量 i7, 文本型
  12. .局部变量 i8, 文本型
  13. .局部变量 i9, 文本型
  14. .局部变量 i10, 整数型
  15. .局部变量 i11, 文本型
  16. .局部变量 年月, 文本型

  17. 年月 = 到文本 (取年份 (日期框2.今天)) + “-” + 到文本 (取月份 (日期框2.今天)) + “-” + 到文本 (取日 (日期框2.今天))
  18. i = “https://api.shenjian.io/promovie/piaofang/?appid=2a64f15f3c2a469616b6fe495945022a&date=” + 年月
  19. i1 = 编码_Utf8到Ansi (网页_访问_对象 (i))
  20. i4.解析 (i1)
  21. .计次循环首 (i4.成员数 (“data”), i2)
  22.     处理事件 ()
  23.     i3 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “]['movie_name']”)
  24.     i5 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “].duration”)
  25.     i6 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “]['totle_office']”)
  26.     i7 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “]['real_office']”)
  27.     i8 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “]['office_ratio']”)
  28.     i9 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “]['show_rate']”)
  29.     i11 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “]['avg_seat_view']”)

  30.     i10 = 超级列表框2.插入表项 (, , , , , )
  31.     超级列表框2.置标题 (i10, 0, 到文本 (i10 + 1))
  32.     超级列表框2.置标题 (i10, 1, i3)
  33.     超级列表框2.置标题 (i10, 2, i5)
  34.     超级列表框2.置标题 (i10, 3, i6)
  35.     超级列表框2.置标题 (i10, 4, i7)
  36.     超级列表框2.置标题 (i10, 5, i8)
  37.     超级列表框2.置标题 (i10, 6, i9)
  38.     超级列表框2.置标题 (i10, 7, i11)
  39.     超级列表框2.保证显示 (i10)
  40. .计次循环尾 ()
复制代码
  1. .版本 2
  2. .支持库 iext
  3. .支持库 EThread

  4. .子程序 _电影票房cha询_被选择

  5. _清空列表0_被选择 ()
  6. 透明标签8.禁止 = 真
  7. 超级列表框2.置列标题 (1, “片名”)
  8. 超级列表框2.置列标题 (2, “上映时间”)
  9. 超级列表框2.置列标题 (3, “总票房”)
  10. 超级列表框2.置列标题 (4, “实时票房(万元)”)
  11. 超级列表框2.置列标题 (5, “票房占比”)
  12. 超级列表框2.删除列 (6)
  13. 超级列表框2.插入列 (6, “排片占比”, 100, , , )
  14. 超级列表框2.插入列 (7, “上座率”, 120, , , )
  15. 启动线程 (&电影票房, , )

  16. .版本 2
  17. .支持库 EThread
  18. .支持库 iext

  19. .子程序 _S4_被单击

  20. 启动线程 (&cha询影院, , )
  21. .判断开始 (透明标签8.禁止 = 真)
  22.     _清空列表0_被选择 ()
  23.     超级列表框2.置列标题 (1, “影投名称”)
  24.     超级列表框2.置列标题 (2, “实时票房”)
  25.     超级列表框2.置列标题 (3, “总人次”)
  26.     超级列表框2.置列标题 (4, “场均人次”)
  27.     超级列表框2.置列标题 (5, “平均票价”)
  28.     超级列表框2.删除列 (6)
  29.     超级列表框2.插入列 (6, “cha询日期”, 238, , , )
  30.     超级列表框2.删除列 (7)
  31.     透明标签8.禁止 = 假
复制代码
  1. .版本 2
  2. .支持库 iext

  3. .子程序 cha询影院
  4. .局部变量 i, 文本型
  5. .局部变量 i1, 文本型
  6. .局部变量 i2, 整数型
  7. .局部变量 i3, 文本型
  8. .局部变量 i4, 类_json
  9. .局部变量 i5, 文本型
  10. .局部变量 i6, 文本型
  11. .局部变量 i7, 文本型
  12. .局部变量 i8, 文本型
  13. .局部变量 i9, 文本型
  14. .局部变量 i10, 整数型
  15. .局部变量 年月日, 文本型

  16. 年月日 = 到文本 (取年份 (日期框2.今天)) + “-” + 到文本 (取月份 (日期框2.今天)) + “-” + 到文本 (取日 (日期框2.今天))
  17. i = “https://api.shenjian.io/promovie/aperture/?appid=2a64f15f3c2a469616b6fe495945022a&city=” + 编辑框3.内容 + “&date=” + 年月日
  18. i1 = 编码_Utf8到Ansi (网页_访问_对象 (i))
  19. i4.解析 (i1)
  20. .计次循环首 (i4.成员数 (“data”), i2)
  21.     处理事件 ()
  22.     i3 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “].title”)
  23.     i5 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “]['real_office']”)
  24.     i6 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “]['person_number']”)
  25.     i7 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “]['average_person_number']”)
  26.     i8 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “]['average_fare']”)
  27.     i9 = i4.取通用属性 (“data[” + 到文本 (i2 - 1) + “].time”)

  28.     i10 = 超级列表框2.插入表项 (, , , , , )
  29.     超级列表框2.置标题 (i10, 0, 到文本 (i10 + 1))
  30.     超级列表框2.置标题 (i10, 1, i3)
  31.     超级列表框2.置标题 (i10, 2, i5)
  32.     超级列表框2.置标题 (i10, 3, i6)
  33.     超级列表框2.置标题 (i10, 4, i7)
  34.     超级列表框2.置标题 (i10, 5, i8)
  35.     超级列表框2.置标题 (i10, 6, i9)
  36.     超级列表框2.保证显示 (i10)


  37. .计次循环尾 ()
复制代码
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表