查看: 28|回复: 0

[易语言] 易语言新手防破解必备检测保护模块v4.4最新版

[复制链接]

192

主题

192

帖子

593

积分

高级会员

Rank: 4

积分
593
发表于 5 天前 | 显示全部楼层 |阅读模式

本帖子中包含更多资源,您需要登录才可以下载或查看更多内容!

您需要 登录 才可以下载附件,没有帐号?注册账号入驻无名

易语言新手防破解必备检测保护模块v4.4最新版
修复
数据被破坏
VM代码类-VMP与SE分明
改变部分检测代码

易语言新手防破解必备检测保护模块v4.4最新版

易语言新手防破解必备检测保护模块v4.4最新版

添加
其他_验证码  '这个可以当作软件的登录验证,zc验证等... 也具有检测调试器功能
新增皮肤效果15个

  1. .版本 2
  2. .支持库 spec

  3. .子程序 __启动窗口_创建完毕

  4. 其他_验证码 (取随机数 (13975, 99999))
  5. 其他_加载皮肤 (2)
  6. _按钮11_被单击 ()  ' 加密S

  7. .子程序 _选择框1_被单击

  8. .如果 (选择框1.选中 = 真)
  9.     命令_屏蔽管理器 ()  ' 任务管理器被屏蔽,禁止使用
  10. .否则
  11.     命令_恢复管理器 ()  ' 恢复了任务管理器
  12. .如果结束


  13. .子程序 _选择框2_被单击

  14. .如果 (选择框2.选中 = 真)
  15.     命令_计时器开启 (5)  ' 到时间后自动结束软件,5秒内取消选择即结束计数器
  16. .否则
  17.     命令_计时器结束 ()
  18. .如果结束


  19. .子程序 _选择框3_被单击

  20. .如果 (选择框3.选中 = 真)
  21.     其他_窗口透明 (取窗口句柄 (), 到整数 (编辑框1.内容))
  22. .否则
  23.     其他_窗口透明 (取窗口句柄 (), 255)  ' 255为恢复,最大为255,最小为0,0就隐身了,建议200左右吧
  24. .如果结束


  25. .子程序 _选择框4_被单击

  26. .如果 (选择框4.选中 = 真)
  27.     命令_锁定程序 (取执行文件名 ())  ' 即本程序自身
  28.     延迟 (到整数 (编辑框2.内容))
  29.     命令_解锁程序 (取执行文件名 ())  ' 即本程序自身
  30. .否则
  31.     命令_解锁程序 (取执行文件名 ())  ' 即本程序自身
  32. .如果结束


  33. .子程序 _选择框5_被单击

  34. .如果 (选择框5.选中 = 真)
  35.     其他_隐藏桌面图标 ()
  36. .否则
  37.     其他_显示桌面图标 ()
  38. .如果结束


  39. .子程序 _按钮1_被单击

  40. .如果 (命令_检测调试器 () = 真)  ' 真=即检测到
  41.     信息框 (“检测到了调试器”, 0, , )
  42.     ' 其他_蓝屏死机 ()
  43. .否则
  44.     信息框 (“未发现调试器”, 0, , )
  45. .如果结束


  46. .子程序 _按钮2_被单击

  47. 命令_检测虚拟机 (3)  ' 注明:1=关机 2=破坏机器 3=不惩罚,直接结束。
  48. ' 如果检测不到,我这里用信息框提示,大家可别这样写,容易被nop
  49. 信息框 (“没有发现虚拟机”, 0, , )

  50. .子程序 _按钮3_被单击

  51. 按钮3.标题 = 其他_取本机登录QQ ()  ' 取本机第一个QQ/也就是任务栏最左边的
复制代码

防破解例子源码.rar

8.61 KB, 下载次数: 0

检测保护模块4.4.rar

984.92 KB, 下载次数: 0

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表