查看: 320|回复: 1

[易语言] 单击复制文本程序源码,双击再ctrl+c变成单击

[复制链接]

211

主题

211

帖子

654

积分

高级会员

Rank: 4

积分
654
发表于 2019-2-10 16:08:26 | 显示全部楼层 |阅读模式
有时候需要频繁的 双击再ctrl+c复制 文本。 这里变成单击(仅此而已~~)。

单击按钮和列表框就可以复制鼠标所在内容 到剪辑版。      

按钮可以编辑需要复制的内容。列表框可以拖入txt。自动记录数据和按钮数量,关闭再打开会是上次的状态。

单击复制文本程序源码,双击再ctrl+c变成单击

单击复制文本程序源码,双击再ctrl+c变成单击

  1. .版本 2
  2. .支持库 spec

  3. .子程序 _按钮_增加_被单击
  4. .局部变量 复制按钮组件, 按钮
  5. .局部变量 文本, 文本型

  6. 按钮当次数量 = 按钮当次数量 + 1
  7. 调试输出 (“按钮当次数量” + 到文本 (按钮当次数量))
  8. 写配置项 (目录, “记录”, “按钮数量”, 到文本 (按钮当次数量))
  9. 复制窗口组件 (按钮_复制标题, 复制按钮组件)
  10. 复制按钮组件.标题 = “”
  11. 复制按钮组件.可视 = 真
  12. 复制按钮组件.顶边 = 按钮顶边 + 按钮高度 × (按钮当次数量 - 1)
  13. 复制按钮组件.标记 = 到文本 (按钮当次数量)
  14. .如果真 (复制按钮组件.顶边 + 按钮高度 > _启动窗口.高度 - 30)
  15.     _启动窗口.高度 = _启动窗口.高度 + 按钮高度
  16. .如果真结束
  17. 事件转移 (复制按钮组件, 按钮_复制标题)
复制代码

[源码]单击复制小工具.rar

533.99 KB, 下载次数: 0

回复

使用道具 举报

0

主题

3663

帖子

7340

积分

论坛元老

Rank: 8Rank: 8

积分
7340
发表于 2019-5-23 10:00:27 | 显示全部楼层
喜怒哀乐,自己掌握!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表