查看: 779|回复: 4

[易语言] 简易安卓QQ机器人源代码【可发送私聊群聊消息】

[复制链接]

211

主题

211

帖子

654

积分

高级会员

Rank: 4

积分
654
发表于 2019-2-5 12:46:16 | 显示全部楼层 |阅读模式
简易的安卓QQ机器人,可发送私聊消息,群聊消息,图片消息
分享后软件使用造成的后果使用者一人承当

简易安卓QQ机器人源代码【可发送私聊群聊消息】

简易安卓QQ机器人源代码【可发送私聊群聊消息】

  1. .版本 2

  2. .子程序 info, 文本型, 公开

  3. NN_插件名 = “测试插件”  ' 插件名
  4. NN_ID = “ceshi_ceshi.nn.dll”  ' 插件ID
  5. NN_版本 = “1.0.0”  ' 插件版本
  6. NN_作者 = “测试”  ' 插件作者
  7. NN_简介 = “测试插件......”  ' 插件简介
  8. 返回 (NN_插件名 + #换行符 + NN_ID + #换行符 + NN_版本 + #换行符 + NN_作者 + #换行符 + NN_简介)

  9. .子程序 EventStart, 文本型, 公开, 插件启动

  10. .如果真 (文件是否存在 (取运行目录 () + “\app\” + NN_ID) = 假)
  11.     创建目录 (取运行目录 () + “\app\” + NN_ID)
  12. .如果真结束
  13. 应用目录 = 取运行目录 () + “\app\” + NN_ID
  14. ' -------------------插件初始化参数可写在下方-------------------------------------
  15. 写到文件 (应用目录 + “\签文.ini”, #签文)
  16. 路径_签文 = 应用目录 + “\签文.ini”
  17. 路径_配置 = 应用目录 + “\配置.ini”
  18. 返回 (“启动成功” + NN_ID)

  19. .子程序 EventStop, 文本型, 公开, 插件停用



  20. 返回 (“插件已停用”)

  21. .子程序 EventGroupMsg, 整数型, 公开, 群消息事件
  22. .参数 fromGroup, 文本型
  23. .参数 fromQQ, 文本型
  24. .参数 msg, 文本型

  25. .如果真 (msg = “抽签”)
  26.     msg = 抽签 (fromQQ, msg)
  27.     api_SendGroupMessage (fromGroup, msg)
  28. .如果真结束
  29. .如果真 (msg = “解签”)
  30.     msg = 解签 (fromQQ, msg)
  31.     api_SendGroupMessage (fromGroup, msg)
  32. .如果真结束
  33. 返回 (0)

  34. .子程序 Menu, 整数型, 公开, 打开插件菜单

  35. 载入 (窗口1, , 假)
  36. 返回 (0)


  37. .子程序 抽签, 文本型
  38. .参数 Wxid, 文本型
  39. .参数 msg, 文本型
  40. .局部变量 签号, 文本型
  41. .局部变量 时间, 文本型
  42. .局部变量 诗, 文本型
  43. .局部变量 返回文本, 文本型

  44. 时间 = 读配置项 (路径_配置, “抽签时间”, Wxid, )
  45. .如果真 (时间 = 到文本 (取日期 (取现行时间 ())))
  46.     签号 = 读配置项 (路径_配置, “签号”, Wxid, )
  47.     诗 = 读配置项 (路径_签文, 签号, “诗”, )
  48.     返回文本 = “小可爱,你已抽过签了,明天才能抽了哦,今天的签文是:” + 字符 (13) + 诗 + 字符 (13) + “解签请发送:解签”
  49.     返回 (返回文本)
  50. .如果真结束
  51. 置随机数种子 ()
  52. 签号 = 到文本 (取随机数 (1, 384))
  53. 诗 = 读配置项 (路径_签文, 签号, “诗”, )
  54. 写配置项 (路径_配置, “抽签时间”, Wxid, 到文本 (取日期 (取现行时间 ())))
  55. 写配置项 (路径_配置, “签号”, Wxid, 签号)
  56. 返回文本 = “签文:” + 字符 (13) + 诗 + 字符 (13) + “解签请发送:解签”
  57. 返回 (返回文本)

  58. .子程序 解签, 文本型
  59. .参数 Wxid, 文本型
  60. .参数 msg, 文本型
  61. .局部变量 签号, 文本型
  62. .局部变量 时间, 文本型
  63. .局部变量 解, 文本型
  64. .局部变量 返回文本, 文本型

  65. 时间 = 读配置项 (路径_配置, “抽签时间”, Wxid, )
  66. .如果真 (时间 = 到文本 (取日期 (取现行时间 ())))
  67.     签号 = 读配置项 (路径_配置, “签号”, Wxid, )
  68.     解 = 读配置项 (路径_签文, 签号, “解”, )
  69.     返回文本 = “解签:” + 字符 (13) + 解
  70.     返回 (返回文本)
  71. .如果真结束
  72. 返回文本 = “小可爱,你今天还没有抽签哦,快来发送:抽签,来看看今天的运气吧。”
  73. 返回 (返回文本)
复制代码

安卓机器人.rar

2.63 MB, 下载次数: 246

回复

使用道具 举报

0

主题

25

帖子

218

积分

中级会员

Rank: 3Rank: 3

积分
218
发表于 2019-2-8 13:03:40 | 显示全部楼层
解压密码多少呢
回复

使用道具 举报

0

主题

16

帖子

281

积分

中级会员

Rank: 3Rank: 3

积分
281
发表于 2019-4-16 18:45:07 | 显示全部楼层
解压密码多少呢
回复

使用道具 举报

0

主题

45

帖子

332

积分

中级会员

Rank: 3Rank: 3

积分
332
发表于 2019-4-26 21:22:15 | 显示全部楼层
学习学习,看一看思路
回复

使用道具 举报

0

主题

9

帖子

20

积分

新手上路

Rank: 1

积分
20
发表于 2019-4-28 20:47:27 | 显示全部楼层
此帖不结,无分可蹭。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表