查看: 1061|回复: 3

[易语言] 易语言写的自定义脚本精灵源代码

[复制链接]

155

主题

155

帖子

480

积分

中级会员

Rank: 3Rank: 3

积分
480
发表于 2018-12-31 12:30:13 | 显示全部楼层 |阅读模式
易语言写的自定义脚本精灵源代码
  1. .版本 2
  2. .支持库 eGrid
  3. .支持库 spec
  4. .支持库 eAPI

  5. .子程序 初始化
  6. .局部变量 表格属性名, 文本型, , "0"
  7. .局部变量 I, 整数型

  8. 高级表格1.置数据 (0, 0, #表格常量.文本型, “属性名”)
  9. 高级表格1.置数据 (0, 1, #表格常量.文本型, “属性值”)
  10. 表格属性名 = { “窗口句柄”, “父句柄”, “顶级句柄”, “窗口标题”, “窗口类名”, “控件类型”, “控件内容”, “窗口位置”, “窗口大小”, “线程ID”, “进程ID”, “进程路径”, “鼠标位置-相对窗口”, “鼠标位置-相对屏幕” }
  11. .计次循环首 (14, I)
  12.     高级表格1.置数据 (I, 0, #表格常量.文本型, 表格属性名 [I])
  13. .计次循环尾 ()
  14. 表格_设置数据 (_启动窗口.取窗口句柄 ())

  15. .子程序 表格_设置数据
  16. .参数 句柄, 整数型
  17. .局部变量 窗口坐标, 精易_坐标
  18. .局部变量 窗口矩形, 精易_矩形

  19. 高级表格1.置数据 (1, 1, #表格常量.文本型, 到文本 (句柄))
  20. 高级表格1.置数据 (2, 1, #表格常量.文本型, 到文本 (窗口_取父句柄 (句柄)))
  21. 高级表格1.置数据 (3, 1, #表格常量.文本型, 到文本 (窗口_取祖句柄 (句柄)))
  22. 高级表格1.置数据 (4, 1, #表格常量.文本型, 窗口_取标题 (句柄))
  23. 高级表格1.置数据 (5, 1, #表格常量.文本型, 窗口_取类名 (句柄))
  24. 高级表格1.置数据 (6, 1, #表格常量.文本型, “未补充”)
  25. 高级表格1.置数据 (7, 1, #表格常量.文本型, 窗口_取控件内容 (句柄))
  26. 窗口坐标 = 窗口_取坐标 (句柄)
  27. 高级表格1.置数据 (8, 1, #表格常量.文本型, “左:” + 到文本 (窗口坐标.横) + “ 顶:” + 到文本 (窗口坐标.纵))
  28. 窗口矩形 = 窗口_取矩形 (句柄)
  29. 高级表格1.置数据 (9, 1, #表格常量.文本型, “宽:” + 到文本 (窗口矩形.右边 - 窗口矩形.左边) + “ 高:” + 到文本 (窗口矩形.底边 - 窗口矩形.顶边))
  30. 高级表格1.置数据 (10, 1, #表格常量.文本型, 到文本 (线程_取ID (句柄)))
  31. 高级表格1.置数据 (11, 1, #表格常量.文本型, “未补充”)
  32. 高级表格1.置数据 (12, 1, #表格常量.文本型, “未补充”)
  33. 窗口坐标 = 鼠标_取窗口坐标 (句柄)
  34. 高级表格1.置数据 (13, 1, #表格常量.文本型, “横:” + 到文本 (窗口坐标.横) + “ 纵:” + 到文本 (窗口坐标.纵))
  35. 高级表格1.置数据 (14, 1, #表格常量.文本型, “横:” + 到文本 (取鼠标水平位置 ()) + “ 纵:” + 到文本 (取鼠标垂直位置 ()))

  36. .子程序 _标签_注册热键_反馈事件, 整数型
  37. .参数 参数一, 整数型
  38. .参数 参数二, 整数型

  39. .如果 (参数一 = ctrl1)
  40.     调试输出 (1)
  41.     全局_窗口句柄 = 取鼠标所在窗口句柄 ()
  42.     表格_设置数据 (全局_窗口句柄)
复制代码

易语言写的自定义脚本精灵源代码

易语言写的自定义脚本精灵源代码

E_脚本.rar

181.31 KB, 下载次数: 6

回复

使用道具 举报

26

主题

2980

帖子

6019

积分

论坛元老

Rank: 8Rank: 8

积分
6019
发表于 2019-1-1 09:48:33 | 显示全部楼层
赞美会让人把正确的事情做下去,把不正确的事情停下来。
回复

使用道具 举报

0

主题

847

帖子

1707

积分

金牌会员

Rank: 6Rank: 6

积分
1707
发表于 2019-1-10 12:38:13 | 显示全部楼层
发现人和人相处互相理解真的很
回复

使用道具 举报

0

主题

1152

帖子

2314

积分

金牌会员

Rank: 6Rank: 6

积分
2314
发表于 2019-12-3 16:15:36 | 显示全部楼层
人生重要的不是所站的位置,而是所朝的方向!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表