您的位置:首页 > 编程语言 > 其他

右上角系统菜单添加自定义子菜单模块

:2.729KB :2021-02-26 15:08:53

.子程序 子菜单_插入子菜单, , 公开, 插入前先进行 子菜单_创建()
.参数 菜单ID值, 整数型, , 默认从1000开始,不同窗口创建的菜单ID不要重复
.参数 菜单名称, 文本型
.参数 默认是否选中, 逻辑型, 可空
.局部变量 菜单ID1, 菜单ID
.局部变量 a

菜单ID1.ID值记录 = 菜单ID值
.判断开始 (默认是否选中)
菜单ID1.是否选中 = 真
a = 8
.默认
菜单ID1.是否选中 = 假
a = 0
.判断结束
加入成员 (菜单ID2, 菜单ID1)
lRet = 添加菜单项_ (lhSysMenu, a, 菜单ID值, 菜单名称) ' MF_STRING = 0(默认不选中) IDM_ABOUT = 1000 MF_CHECK=8(默认选中)
易语言右上角系统菜单添加自定义菜单模块例子。

蓝奏云直链提取例程
通用文本颠倒、倒叙、数组颠倒、数组倒序

同类资源